#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\/books\/[^\/]"
Local $sString = "stuffbefore/books/the-tel-aviv-farmers-market/?fb_action_ids=10201758621202245&fb_action_types=og.likes"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")