// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\/books\/[^\/]").unwrap();
let string = "stuffbefore/books/the-tel-aviv-farmers-market/?fb_action_ids=10201758621202245&fb_action_types=og.likes";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}