import Foundation
let pattern = #"\/books\/[^\/]"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"stuffbefore/books/the-tel-aviv-farmers-market/?fb_action_ids=10201758621202245&fb_action_types=og.likes"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}