using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\/books\/[^\/]";
string input = @"stuffbefore/books/the-tel-aviv-farmers-market/?fb_action_ids=10201758621202245&fb_action_types=og.likes";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}