package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\/books\/[^\/]`)
var str = `stuffbefore/books/the-tel-aviv-farmers-market/?fb_action_ids=10201758621202245&fb_action_types=og.likes`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}