re = /\/books\/[^\/]/
str = 'stuffbefore/books/the-tel-aviv-farmers-market/?fb_action_ids=10201758621202245&fb_action_types=og.likes'
# Print the match result
str.match(re) do |match|
puts match.to_s
end