using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\ba\b\s\bleg[\w]+bb\b\s\b[\w]+\b";
string input = @"This is grappa legaobb duh dang...
That is a legobatmanbb cave hahaha";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}