import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\ba\\b\\s\\bleg[\\w]+bb\\b\\s\\b[\\w]+\\b";
final String string = "This is grappa legaobb duh dang...\n\n"
+ "That is a legobatmanbb cave hahaha";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}