package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\ba\b\s\bleg[\w]+bb\b\s\b[\w]+\b`)
var str = `This is grappa legaobb duh dang...
That is a legobatmanbb cave hahaha`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}