#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?<=[A-Za-z])(?=[A-Z][a-z])"
Local $sString = "MASCULINOFecha de NacimientoLugar de Nacimiento" & @CRLF & _
"CASADONivel Educativo"
Local $sSubst = "\n"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)