use strict;
my $str = 'MASCULINOFecha de NacimientoLugar de Nacimiento
CASADONivel Educativo';
my $regex = qr/(?<=[A-Za-z])(?=[A-Z][a-z])/p;
my $subst = '\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";