const regex = /(?<=[A-Za-z])(?=[A-Z][a-z])/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=[A-Za-z])(?=[A-Z][a-z])', 'g')
const str = `MASCULINOFecha de NacimientoLugar de Nacimiento
CASADONivel Educativo`;
const subst = `\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);