$re = '/(?<=[A-Za-z])(?=[A-Z][a-z])/';
$str = 'MASCULINOFecha de NacimientoLugar de Nacimiento
CASADONivel Educativo';
$subst = "\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;