re = /(?<=[A-Za-z])(?=[A-Z][a-z])/
str = 'MASCULINOFecha de NacimientoLugar de Nacimiento
CASADONivel Educativo'
subst = '\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result