using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=[A-Za-z])(?=[A-Z][a-z])";
string substitution = @"\n";
string input = @"MASCULINOFecha de NacimientoLugar de Nacimiento
CASADONivel Educativo";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}