#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[^\s@#$%^&+=_]*[@#$%^&+=_]\S*"
Local $sString = "abc 123 abc12def abc@dd44-@#$$%^&^*() abcdd44-*()" & @CRLF & _
"abc123abc12defabc@dd44-@#$$%^&^*()abcdd44-*()" & @CRLF & _
"abc 123 abc12def @abc@dd44-@#$$%^&^*() abcdd44-*()"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")