re = /[^\s@#$%^&+=_]*[@#$%^&+=_]\S*/m
str = 'abc 123 abc12def abc@dd44-@#$$%^&^*() abcdd44-*()
abc123abc12defabc@dd44-@#$$%^&^*()abcdd44-*()
abc 123 abc12def @abc@dd44-@#$$%^&^*() abcdd44-*()'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end