import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[^\\s@#$%^&+=_]*[@#$%^&+=_]\\S*";
final String string = "abc 123 abc12def abc@dd44-@#$$%^&^*() abcdd44-*()\n"
+ "abc123abc12defabc@dd44-@#$$%^&^*()abcdd44-*()\n"
+ "abc 123 abc12def @abc@dd44-@#$$%^&^*() abcdd44-*()";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}