using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^\s@#$%^&+=_]*[@#$%^&+=_]\S*";
string input = @"abc 123 abc12def abc@dd44-@#$$%^&^*() abcdd44-*()
abc123abc12defabc@dd44-@#$$%^&^*()abcdd44-*()
abc 123 abc12def @abc@dd44-@#$$%^&^*() abcdd44-*()";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}