package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^\s@#$%^&+=_]*[@#$%^&+=_]\S*`)
var str = `abc 123 abc12def abc@dd44-@#$$%^&^*() abcdd44-*()
abc123abc12defabc@dd44-@#$$%^&^*()abcdd44-*()
abc 123 abc12def @abc@dd44-@#$$%^&^*() abcdd44-*()`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}