# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(;.*)\b(TODO\b.*)/$1"address": /gm;t' <<< "; comment that contains TODO - correct
TODO := 5 ; comment that isn't valid t-o-d-o
; regular comment
_x := 5 ; this is also valid TODO"