const regex = /(;.*)\b(TODO\b.*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(;.*)\\b(TODO\\b.*)', 'gm')
const str = `; comment that contains TODO - correct
TODO := 5 ; comment that isn't valid t-o-d-o
; regular comment
_x := 5 ; this is also valid TODO`;
const subst = `$1"address": `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);