// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(;.*)\b(TODO\b.*)").unwrap();
let string = "; comment that contains TODO - correct
TODO := 5 ; comment that isn't valid t-o-d-o
; regular comment
_x := 5 ; this is also valid TODO";
let substitution = "$1\"address\": ";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}