use strict;
my $str = '; comment that contains TODO - correct
TODO := 5 ; comment that isn\'t valid t-o-d-o
; regular comment
_x := 5 ; this is also valid TODO';
my $regex = qr/(;.*)\b(TODO\b.*)/mp;
my $subst = '$1"address": ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";