using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(;.*)\b(TODO\b.*)";
string substitution = @"$1""address"": ";
string input = @"; comment that contains TODO - correct
TODO := 5 ; comment that isn't valid t-o-d-o
; regular comment
_x := 5 ; this is also valid TODO";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}