import Foundation
let pattern = #"(;.*)\b(TODO\b.*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
; comment that contains TODO - correct
TODO := 5 ; comment that isn't valid t-o-d-o
; regular comment
_x := 5 ; this is also valid TODO
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"address": "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)