#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<=Address:\n\n)[a-zA-Z\d'-,\s]*(?=\n\n)"
Local $sString = "Billing Address:" & @CRLF & _
"" & @CRLF & _
"Harry Smith" & @CRLF & _
"3423 My Lane" & @CRLF & _
"SOME CITY, CA 94105" & @CRLF & _
"United States" & @CRLF & _
"" & @CRLF & _
"Some more text"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")