use strict;
my $str = 'Billing Address:
Harry Smith
3423 My Lane
SOME CITY, CA 94105
United States
Some more text';
my $regex = qr/(?<=Address:\n\n)[a-zA-Z\d'-,\s]*(?=\n\n)/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}