import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=Address:\\n\\n)[a-zA-Z\\d'-,\\s]*(?=\\n\\n)";
final String string = "Billing Address:\n\n"
+ "Harry Smith\n"
+ "3423 My Lane\n"
+ "SOME CITY, CA 94105\n"
+ "United States\n\n"
+ "Some more text";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}