import re
regex = re.compile(r"(?<=Address:\n\n)[a-zA-Z\d'-,\s]*(?=\n\n)")
test_str = ("Billing Address:\n\n"
"Harry Smith\n"
"3423 My Lane\n"
"SOME CITY, CA 94105\n"
"United States\n\n"
"Some more text")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")