using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=Address:\n\n)[a-zA-Z\d'-,\s]*(?=\n\n)";
string input = @"Billing Address:
Harry Smith
3423 My Lane
SOME CITY, CA 94105
United States
Some more text";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}