using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"def\s+(\w+)\((\w+),\s*(\w+)\):";
string substitution = @".macro \1_imm \2 \3";
string input = @"def wrloc(imm_value, imm_address):";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}