re = /def\s+(\w+)\((\w+),\s*(\w+)\):/
str = 'def wrloc(imm_value, imm_address):'
subst = '.macro \\1_imm \\2 \\3'
result = str.sub(re, subst)
# Print the result of the substitution
puts result