import re
regex = re.compile(r"def\s+(\w+)\((\w+),\s*(\w+)\):")
test_str = "def wrloc(imm_value, imm_address):"
subst = ".macro \\1_imm \\2 \\3"
result = regex.sub(subst, test_str, count=1)
if result:
print(result)