import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "def\\s+(\\w+)\\((\\w+),\\s*(\\w+)\\):";
final String string = "def wrloc(imm_value, imm_address):";
final String subst = ".macro \\1_imm \\2 \\3";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}