package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`def\s+(\w+)\((\w+),\s*(\w+)\):`)
var str = []byte(`def wrloc(imm_value, imm_address):`)
var substitution = []byte(".macro \1_imm \2 \3")
var count = 1 // negative counter is equivalent to global case (replace all)
str = re.ReplaceAllStringFunc(str, func(s string) string {
if count == 0 {
return s
}
count -= 1
return re.ReplaceAllString(s, substitution)
})
fmt.Println(string(str))
}