#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(https?:\/\/(www\.)?youtube\.com\/.*v=+.*)|(https?:\/\/youtu\.be\/+.*)|(.*src=.https?:\/\/(www\.)?youtube\.com\/v\/.*)|(.*src=.https?:\/\/(www\.)?youtube\.com\/embed\/+.*)"
Local $sString = "https://youtu.be/0zM3nApSvMg"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")