using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(https?:\/\/(www\.)?youtube\.com\/.*v=+.*)|(https?:\/\/youtu\.be\/+.*)|(.*src=.https?:\/\/(www\.)?youtube\.com\/v\/.*)|(.*src=.https?:\/\/(www\.)?youtube\.com\/embed\/+.*)";
string input = @"https://youtu.be/0zM3nApSvMg";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}