const regex = /(https?:\/\/(www\.)?youtube\.com\/.*v=+.*)|(https?:\/\/youtu\.be\/+.*)|(.*src=.https?:\/\/(www\.)?youtube\.com\/v\/.*)|(.*src=.https?:\/\/(www\.)?youtube\.com\/embed\/+.*)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(https?:\\\/\\\/(www\\.)?youtube\\.com\\\/.*v=+.*)|(https?:\\\/\\\/youtu\\.be\\\/+.*)|(.*src=.https?:\\\/\\\/(www\\.)?youtube\\.com\\\/v\\\/.*)|(.*src=.https?:\\\/\\\/(www\\.)?youtube\\.com\\\/embed\\\/+.*)', '')
const str = `https://youtu.be/0zM3nApSvMg`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}