// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(https?:\/\/(www\.)?youtube\.com\/.*v=+.*)|(https?:\/\/youtu\.be\/+.*)|(.*src=.https?:\/\/(www\.)?youtube\.com\/v\/.*)|(.*src=.https?:\/\/(www\.)?youtube\.com\/embed\/+.*)").unwrap();
let string = "https://youtu.be/0zM3nApSvMg";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}