$re = '/(https?:\/\/(www\.)?youtube\.com\/.*v=+.*)|(https?:\/\/youtu\.be\/+.*)|(.*src=.https?:\/\/(www\.)?youtube\.com\/v\/.*)|(.*src=.https?:\/\/(www\.)?youtube\.com\/embed\/+.*)/';
$str = 'https://youtu.be/0zM3nApSvMg';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);