import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(https?:\\/\\/(www\\.)?youtube\\.com\\/.*v=+.*)|(https?:\\/\\/youtu\\.be\\/+.*)|(.*src=.https?:\\/\\/(www\\.)?youtube\\.com\\/v\\/.*)|(.*src=.https?:\\/\\/(www\\.)?youtube\\.com\\/embed\\/+.*)";
final String string = "https://youtu.be/0zM3nApSvMg";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}