# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[^\S]*(\w*)(?:\s*)(?:\s*\([^()]*\)\S*)*/$1*/gm;t' <<< "John (Juan, Jonathan, Jon, Jonny) James Doe (born on January 1, 1900) (Canada) James John (Juan, Jonathan, Jon, Jonny) James Doe (born on January 1, 1900) (Canada) James"