re = /[^\S]*(\w*)(?:\s*)(?:\s*\([^()]*\)\S*)*/m
str = 'John (Juan, Jonathan, Jon, Jonny) James Doe (born on January 1, 1900) (Canada) James John (Juan, Jonathan, Jon, Jonny) James Doe (born on January 1, 1900) (Canada) James'
subst = '$1*'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result