package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[^\S]*(\w*)(?:\s*)(?:\s*\([^()]*\)\S*)*`)
var str = `John (Juan, Jonathan, Jon, Jonny) James Doe (born on January 1, 1900) (Canada) James John (Juan, Jonathan, Jon, Jonny) James Doe (born on January 1, 1900) (Canada) James`
var substitution = "$1*"
fmt.Println(re.ReplaceAllString(str, substitution))
}