const regex = /[^\S]*(\w*)(?:\s*)(?:\s*\([^()]*\)\S*)*/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^\\S]*(\\w*)(?:\\s*)(?:\\s*\\([^()]*\\)\\S*)*', 'gm')
const str = `John (Juan, Jonathan, Jon, Jonny) James Doe (born on January 1, 1900) (Canada) James John (Juan, Jonathan, Jon, Jonny) James Doe (born on January 1, 1900) (Canada) James`;
const subst = `$1*`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);