using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".+(?:[^n]|[^i]n|[^b]in|[^.]bin)\.js$\n";
string input = @"file1.js
file2.src.js
file3.bin.src.js
file1.binbin.js
file1.in.js
file1.b.js
But not:
file1.bin.js
file2.src.bin.js
bla.js
.js";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}