// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m).+(?:[^n]|[^i]n|[^b]in|[^.]bin)\.js$\n").unwrap();
let string = "file1.js
file2.src.js
file3.bin.src.js
file1.binbin.js
file1.in.js
file1.b.js
But not:
file1.bin.js
file2.src.bin.js
bla.js
.js";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}