import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".+(?:[^n]|[^i]n|[^b]in|[^.]bin)\\.js$\\n";
final String string = "file1.js\n"
+ "file2.src.js\n"
+ "file3.bin.src.js\n"
+ "file1.binbin.js\n"
+ "file1.in.js\n"
+ "file1.b.js\n"
+ "But not:\n\n"
+ "file1.bin.js\n"
+ "file2.src.bin.js\n\n"
+ "bla.js\n"
+ ".js";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}