re = /.+(?:[^n]|[^i]n|[^b]in|[^.]bin)\.js$\n/m
str = 'file1.js
file2.src.js
file3.bin.src.js
file1.binbin.js
file1.in.js
file1.b.js
But not:
file1.bin.js
file2.src.bin.js
bla.js
.js'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end